Subaru Impreza 1.5i NA 79KW 107HP 2010

User topics relating to hardware that interfaces PCs to ECUs

Moderator: Freon

Subaru Impreza 1.5i NA 79KW 107HP 2010

Postby LechnerTuning » Fri May 25, 2012 3:20 am

Hello,

anybody knows if we can read/write this Subaru Impreza 1.5i NA 79KW 107HP 2010 with tactrix ?

Thank you
Best Regards
LechnerTuning
 
Posts: 2
Joined: Tue Mar 06, 2012 10:03 pm

Re: Subaru Impreza 1.5i NA 79KW 107HP 2010

Postby Sasha_A80 » Fri May 25, 2012 3:32 am

What processor chip is it based on ?
Renesas SH7058 or UnisiaJecs WA12212970 ?
Sasha_A80
 
Posts: 102
Joined: Sun Aug 31, 2008 3:04 am
Location: Saratov, Russia

Re: Subaru Impreza 1.5i NA 79KW 107HP 2010

Postby LechnerTuning » Fri May 25, 2012 3:47 am

Hello,

sorry we dont have this car here, we just know the engine number (EL15) but this wont help
LechnerTuning
 
Posts: 2
Joined: Tue Mar 06, 2012 10:03 pm

Re: Subaru Impreza 1.5i NA 79KW 107HP 2010

Postby Sasha_A80 » Fri May 25, 2012 4:47 am

EL15 probably uses Hitachi ecu and OP2 is out of help.
If there is SH7058 chip inside you may use SHbootmode for reflash provided you manage to upload stock ROM image.
Older cars used M32R base Hitachi ecu.
Sasha_A80
 
Posts: 102
Joined: Sun Aug 31, 2008 3:04 am
Location: Saratov, Russia

Re: Subaru Impreza 1.5i NA 79KW 107HP 2010

Postby Jochen_145 » Fri May 25, 2012 6:07 am

I reat about a MY08 1.5L witch was reat and wirted via ECUflash. You can find this threat in a european subaru community.
I would like to test it two, but th day I was at the Subaru Station, there was no 1.5L to read-out.

But it seems that, the > MY08 1.5L work with ECUFalsh

Any news wellcome :D
Jochen_145
 
Posts: 70
Joined: Thu Nov 12, 2009 8:45 am

Re: Subaru Impreza 1.5i NA 79KW 107HP 2010

Postby Jochen_145 » Fri Aug 31, 2012 4:45 am

Just for inforamtion:

I tryed to readout a MY2008 1.5i NA 107HP with ECUflash yesterday and didn´t have any suggsess :cry:

Tractrix can connect and readout FIN, CIN and Rom-ID, but failed at seed-and-key.

So maybe only a few things have to chanced to made ECUflash to be able to readout, but at this time it doesn´t work

BR Jochen
Jochen_145
 
Posts: 70
Joined: Thu Nov 12, 2009 8:45 am

Re: Subaru Impreza 1.5i NA 79KW 107HP 2010

Postby matech » Wed Oct 10, 2012 6:32 am

Bought Tactrix cable a few weeks ago. Already done a 2001 wrx and everything worked fine.

Today i try with a 2010 impreza 2.5i N/A, but the EcuFlash closes the interface comunication after seed key. It was my understanding that this car was supported: isn't it? It has the start/stop button, no key, but I pressed OK on EcuFlash window immediatly after pressing the start button on the car.

I found no-where infos about the procedure for the start/stop provided vehicles....

PS: After every "read try", the fans start going on-off

thanks
matech
 
Posts: 1
Joined: Wed Oct 10, 2012 6:24 am


Return to Interface Hardware

Who is online

Users browsing this forum: Google [Bot] and 3 guests