EcuFlash Should Log Test Mode Connector Status for Subarus

Developer topics relating to software that reflashes or modifes ECU code and data

Moderator: Freon

EcuFlash Should Log Test Mode Connector Status for Subarus

Postby Jon [in CT] » Thu Aug 02, 2007 11:35 am

Many of the problems with reading or reflashing Subaru ROMs reported in these forums arise from the fact that the two green test mode connectors weren't joined together. The status of the test mode connectors is a parameter which can be obtained from the ECU using a standard SSM2 query.

After data is returned from the SSM2 Init command, the flag in byte 20 would be inspected to see whether test mode connector status is supported. If it isn't (unlikely) then EcuFlash would log the message "Test Mode Connector Status: Unknown" and continue on. Otherwise, EcuFlash would retrieve the status using the 0xA8 command to read the byte at 0x061. Then it would log either "Test Mode Connector Status: Connected" or "Test Mode Connector Status: Disconnected" and continue on.
Jon [in CT]
 
Posts: 352
Joined: Sat Jan 01, 2005 10:23 am

Postby Freon » Thu Aug 02, 2007 12:27 pm

Seems like a good idea.
Freon
 
Posts: 700
Joined: Thu Nov 17, 2005 5:50 pm
Location: Indianapolis, IN

Postby merchgod » Thu Aug 02, 2007 1:40 pm

Definitely a good idea. An message box saying, "connect your green test mode connectors, moron, since you failed to research anything before messing with your ecu" would be good as well. j/k but still a good idea.
merchgod
 
Posts: 243
Joined: Fri Sep 29, 2006 10:17 am


Return to Reflashing Software

Who is online

Users browsing this forum: Bing [Bot] and 1 guest