SMP-safe drivers?

Developer topics relating to hardware that interfaces PCs to ECUs

Moderator: Freon

SMP-safe drivers?

Postby LGT-3-6 » Fri Apr 04, 2008 5:01 pm

Anyone have a clue as to the effort involved? I've never done kernel debugging on XP, but I can give it a go if someone gives me a hand.
LGT-3-6
 
Posts: 50
Joined: Fri Jun 03, 2005 1:12 pm

Postby Jon [in CT] » Sat Apr 05, 2008 8:06 am

Drivers for what? Maybe the problem is in your application. What are you trying to run?
Jon [in CT]
 
Posts: 352
Joined: Sat Jan 01, 2005 10:23 am

Postby LGT-3-6 » Sat Apr 05, 2008 10:15 am

Jon [in CT] wrote:Drivers for what? Maybe the problem is in your application. What are you trying to run?
Drivers for the OpenPort 1.3
It is definitely not an application problem. Applications can't hardlock the kernel no matter how hard they try.
LGT-3-6
 
Posts: 50
Joined: Fri Jun 03, 2005 1:12 pm

Postby Jon [in CT] » Sat Apr 05, 2008 4:50 pm

Again, what application are you running?
Jon [in CT]
 
Posts: 352
Joined: Sat Jan 01, 2005 10:23 am

Postby LGT-3-6 » Sat Apr 05, 2008 5:28 pm

street tuner.
LGT-3-6
 
Posts: 50
Joined: Fri Jun 03, 2005 1:12 pm

Postby LGT-3-6 » Sat Apr 05, 2008 9:32 pm

And of course, this did not matter.

I updated the driver pack with the latest FTDI drivers, which is WHQL certified and SMP safe. It would be nice if someone with a bench-flasher would double check that flashing works properly, attached.
Attachments
3-13-2008 FTDI.zip
(795.73 KiB) Downloaded 259 times
LGT-3-6
 
Posts: 50
Joined: Fri Jun 03, 2005 1:12 pm


Return to Interface Hardware

Who is online

Users browsing this forum: No registered users and 1 guest