problems with logcfg.txt

problems with logcfg.txt

Postby rxeght » Tue Feb 26, 2013 1:34 pm

First off, I am working on a 2004 AUDM Mazda RX8.

I have a logcfg and its at least logging. rpm, maf, coolant_temp, wbo2_commanded and calc_load are all fine however I have a few problems I am hoping someone can help me with:

1. stft & ltft show values like 95.3125 and 101.5630 respectively instead of +4.6875 and -1.5630, secondly the values dont seem to match up with other tools like Dash Commander which is showing a pretty rock solid -3.1 for ltft (101.5630 is also pretty rock solid in the output of my log file). To fix the 95.3125 instead of +5.3125 I could just do:

paramname=stft1
mode=0x01
paramid=0x06
databits=8
scalingrpn=128,x,-,0.78125,*

But that doesn't help with the fact the numbers don't look right.

2. Again, Dash commander shows 14.9/15 actual AFR (Lambda of around 1.00-1.05) yet I am seeing values like 1.4328 in my log file. The following is commanded and actual lambda from a log file

cmded actual
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328
0.9045 1.4328

Any help on these issues will be appreciated.

my logcfg
-----------------------------------------------
paramname=rpm
mode=0x01
paramid=0x0C
databits=16
scalingrpn=x,0.25,*

paramname=maf
mode=0x01
paramid=0x10
databits=16
scalingrpn=x,0.01,*

paramname=coolant_temp
mode=0x01
paramid=0x05
databits=8
scalingrpn=x,40,-

paramname=calc_load
mode=0x01
paramid=0x04
databits=8
scalingrpn = x,0.3921569,*

paramname=stft1
mode=0x01
paramid=0x06
databits=8
scalingrpn=x,0.78125,*

paramname=ltft1
mode=0x01
paramid=0x07
databits=8
scalingrpn=x,0.78125,*

paramname=wbo2_commanded
mode=0x01
paramid=0x44
databits=16
scalingrpn=x,0.0000305,*

paramname=wbo2_actual
mode=0x01
paramid=0x34
databits=16
;offsetbits=0
scalingrpn=x,0.0000305,*


Andrew
rxeght
 
Posts: 2
Joined: Sun Aug 05, 2012 6:51 pm

Re: problems with logcfg.txt

Postby rxeght » Thu Feb 28, 2013 2:19 am

Anyone???
rxeght
 
Posts: 2
Joined: Sun Aug 05, 2012 6:51 pm

Re: problems with logcfg.txt

Postby mporeda » Tue Mar 12, 2013 4:11 pm

you just need to subtract your final value from 100. Change your scalingrpn entry to:

scalingrpn=100,x,0.78125,*,-

That should solve your problem so that you'll see +4.6875 and -1.5630 instead of 95.3125 and 101.5630.
mporeda
 
Posts: 38
Joined: Tue May 01, 2012 4:43 pm


Return to Openport Stand-Alone Logging Beta

Who is online

Users browsing this forum: No registered users and 2 guests

cron