Page 1 of 8

Openport standalone Config tool Beta

PostPosted: Sat Oct 31, 2009 5:41 pm
by freakin
I have created a little app that will build the logcfg.txt file and i need some feedback

Current limitations and brief description
*You must have a working romraider installed (it gets the logger.xml and ecu_defs.xml file location from the romraider settings.xml file)
*it currently only does standard and extended params, not calculated ones.
*its a bit rough round the edges
*you have the option of the defogger, rpm or coolant Temp for start stopping
*there is no priority stuff in yet
*some parameters dont work because they are too long (if someone can work out the max length for me that would be appreciated)

Basic instructions

Open app (duh)
select your ECU from the drop down list
Select the parameters by ticking the boxes
click make logcfg.txt
copy logcfg.txt to your OP2 sd card
Test and provide me with some feed back as to what doesn't work
If the application errors then it will create an output text file, please forward this to me

[img]http://bit.ly/1C5Ogh[/img]

[attachment=0]logcfg.exe[/attachment]

someone asked if i would take a donation for my work, after thinking about it for a while i have decided that if any one else wants to donate then it can go towards the keep the wife happy fund for me spending hours at the computer.

I am not asking for anyone to donate and my application is free for all to use so enjoy and donate if your feeling a bit flush and want to keep the wife happy :).

[url=https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=9446242][img]https://www.paypal.com/en_US/GB/i/btn/btn_donateCC_LG.gif[/img][/url]

Re: Openport standalone Config tool Beta

PostPosted: Sat Oct 31, 2009 7:10 pm
by mickeyd2005
This looks like a cool app. However, I get a run-time error '91': Object variable or With block variable not set.

Any advice?

Re: Openport standalone Config tool Beta

PostPosted: Sat Oct 31, 2009 8:30 pm
by CasopoliS
Very cool app. Runtime error as well. Runtime error 5: Invalid procedure call or argument. The error comes when I select my ECU from the list.

Vista 64bit

Re: Openport standalone Config tool Beta

PostPosted: Sat Oct 31, 2009 9:25 pm
by enthusiast
Where does it write the config file at? I cannot find it.

Works on XP SP3 with .Net 3.5 SP1

EDIT: Re-read your instructions and saw that it writes to c:\logcfg.txt.

Re: Openport standalone Config tool Beta

PostPosted: Sat Oct 31, 2009 10:13 pm
by legaulois
i have runtime error 70 - Permission denied :(
in vista and framework 3.5

Re: Openport standalone Config tool Beta

PostPosted: Sat Oct 31, 2009 10:26 pm
by legaulois
It works, should start in Administrator :D :wink:

Re: Openport standalone Config tool Beta

PostPosted: Sun Nov 01, 2009 12:24 am
by freakin
To all those with errors I have added some error handling, it should create a text file in the same directory as the exe. Can you send me the output please and I will investigate

Re: Openport standalone Config tool Beta

PostPosted: Sun Nov 01, 2009 1:38 am
by freakin
updated version added to top post listbox control tidied and some logging added.

Has anyone been able to validate my RPN calculations ?

Re: Openport standalone Config tool Beta

PostPosted: Sun Nov 01, 2009 2:49 am
by freakin
apart from RPM and the defogger what are the common on/off controls?

Re: Openport standalone Config tool Beta

PostPosted: Sun Nov 01, 2009 3:19 am
by legaulois
I have a TSI 2008 and at the moment this type of addressing 0xFF63FC does not work

Code: Select all
type = ssmcan

paramname = A/F_Sensor_#1(AFR)
paramid = 0x000046
databits = 8
scalingrpn = x,128,/,14.7,*

paramname = IAM(multiplier)
paramid = 0x0000F9
databits = 8
scalingrpn = x,16,/

paramname = Engine_Load_(4-Byte)*(g/rev)
paramid = 0xFF65D4
isfloat = 1
scalingrpn = x

paramname = CL/OL_Fueling*(status)
paramid = 0xFF9CF1
databits = 8
scalingrpn = x,6,+

paramname = Fine_Learning_Knock_Correction_(4-byte)*(degrees)
paramid = 0xFF7CDC
isfloat = 1
scalingrpn = x

paramname = Knock_Correction_Advance_(4-byte)*(degrees)
paramid = 0xFF7C3C
isfloat = 1
scalingrpn = x

paramname = Fuel_Injector_#1_Latency_(4-byte)*(ms)
paramid = 0xFF6F44
isfloat = 1
scalingrpn = x,.001,*

paramname = Manifold_Absolute_Pressure_(4-byte)*(bar_absolute)
paramid = 0xFF63FC
isfloat = 1
scalingrpn = x,0.001333224,*

paramname = Ignition_Base_Timing*(degrees)
paramid = 0xFF7988
isfloat = 1
scalingrpn = x

paramname = Requested_Torque*(raw_ecu_value)
paramid = 0xFF7FA4
isfloat = 1
scalingrpn = x

paramname = A/F_Correction_#1_(2-byte)**(%)
paramid = 0xFF6A2A
databits = 16
scalingrpn = x,.01220703,*,100,-

paramname = A/F_Sensor_#1_(2-byte)**(estimated_AFR)
paramid = 0xFF6A18
databits = 16
scalingrpn = x,.0001220703,*,14.7,*

paramname = IAM_(1-byte)**(multiplier)
paramid = 0xFF6A4F
databits = 8
scalingrpn = x,.0625,*

paramname = defogger_sw
paramid = 0x64
databits = 1
offsetbits = 5
isvisible = 0

conditionrpn = defogger_sw,1,==
Action = start

conditionrpn = defogger_sw,0,==
action = stop

Re: Openport standalone Config tool Beta

PostPosted: Sun Nov 01, 2009 3:59 am
by freakin
Do you mean generally or as an output from the tool? Also have you tried the other mode, I read somewhere that one supports the extra bits on newer ecu's but runs slower.

Re: Openport standalone Config tool Beta

PostPosted: Sun Nov 01, 2009 6:26 am
by CasopoliS
Ok now it lets me select my ECU but hangs up and gets into a huge loop and locks up. It created a 6MB log file full of errors. I have to kill the process, the "X" does not work in the application.

Code: Select all
20091101091946   ERROR   logcfg   Form1   loadDefs   ERROR:5(10150) Invalid procedure call or argument      
20091101091946   ERROR   logcfg   Form1   loadDefs   ERROR:424(10160) Object required      
20091101091946   ERROR   logcfg   Form1   loadDefs   ERROR:424(10170) Object required      
20091101091946   ERROR   logcfg   Form1   loadDefs   ERROR:424(10200) Object required      
20091101091946   ERROR   logcfg   Form1   loadDefs   ERROR:424(10220) Object required      
20091101091946   ERROR   logcfg   Form1   loadDefs   ERROR:424(10200) Object required      
20091101091946   ERROR   logcfg   Form1   loadDefs   ERROR:424(10220) Object required

Re: Openport standalone Config tool Beta

PostPosted: Sun Nov 01, 2009 7:18 am
by freakin
CasopoliS, can you download the version 1.2.23 at the top should enable me to see what the problem is.If it errors can you get a screen shot of the message box that will appear with the app in the back ground so I can see the bottom box

you could also try putting these two files in your windows\system32 directory if they don't already exist (don't overwrite your existing ones if they exist)

msxml2.dll.txt
you need to remove the .txt extenion from the filename (you may not be able to see this by default in explorer)
(685 KiB) Downloaded 777 times


scrrun.dll.txt
you need to remove the .txt extenion from the filename (you may not be able to see this by default in explorer)
(168 KiB) Downloaded 726 times

Re: Openport standalone Config tool Beta

PostPosted: Sun Nov 01, 2009 10:13 am
by mickeyd2005
freakin wrote:apart from RPM and the defogger what are the common on/off controls?


Coolant temperature would be a good trigger.

Re: Openport standalone Config tool Beta

PostPosted: Sun Nov 01, 2009 10:17 am
by enthusiast
When I click on "Choose logging start stop" and select use "Defogger" the output in the LogCfg.txt is:

Code: Select all
conditionrpn = engine_speed,1,==
Action = start

conditionrpn = defogger_sw,0,==
action = stop


should be:

Code: Select all
;conditionrpn = defogger_sw,1,==
;action = start

;conditionrpn = defogger_sw,0,==
;action = stop