Openport Stand-Alone Logging Beta

Re: Openport Stand-Alone Logging Beta

Postby gwigga » Wed Apr 25, 2012 2:45 am

I want to use RPm to trigger the logging to start

this was copied from another person I know but the it doesn't work

the logcfg.out file states theres something wrong with it

conditionrpn = RPM,0,>
action = start
;
conditionrpn = RPM,0,==
action = stop

also could you tell me what to set to start the logging at 2000rpm and finsih when it drops below 2000
gwigga
 
Posts: 2
Joined: Wed Oct 05, 2011 4:24 am

Re: Openport Stand-Alone Logging Beta

Postby helmut_hair » Fri Apr 27, 2012 9:27 am

cboles wrote:
* The current version of the beta has no power management, and the OBD port is always on, so it is possible to drain your battery if you leave the OP2 plugged in for several days while your car is off.

Is it possible that power management can be implemented? I'm looking at doing some sort of permanent install of the OP2 in my car.
helmut_hair
 
Posts: 5
Joined: Fri Apr 08, 2011 1:23 am

Re: Openport Stand-Alone Logging Beta

Postby endrswrd » Thu Oct 25, 2012 8:44 am

I am looking for some help generating my logcfg.txt file.

Car is 2011 USDM WRX STi 5 door

ECUID : AE5IB00V. Although, The rom currently flashed on the car may be the sedan rom. I plan on copying my tune back to the correct rom for the car, even though they both work just as expected.

I have this so far

Code: Select all
Code:
type=ssmk

paramname = Coolant
paramid = 0x000008
databits = 8
scalingrpn = x,40,-

paramname = A/F_Correction_#1(%)
paramid = 0x000009
databits = 8
scalingrpn = x,128,-,100,*,128,/

paramname = A/F_Learning_#1(%)
paramid = 0x00000A
databits = 8
scalingrpn = x,128,-,100,*,128,/

paramname = RPM
paramid = 0x00000E
databits = 16
scalingrpn = x,0.25,*
sampinterval = 5


paramname = Throttle Opening(%)
paramid = 0x000015
databits = 8
scalingrpn = x,0.3921569,*


paramname = A/F_Sensor_#1(AFR)
paramid = 0x000046
databits = 8
scalingrpn = x,128,/,14.7,*

paramname = CL/OL_Fueling*(status)
paramid = 0xFFA44D
databits = 8
scalingrpn = x,6,+

paramname = MAFG/s
paramid = 0x000013
databits = 16            
scalingrpn = x,0.01,*
sampinterval = 2

paramname = MAFv
paramid = 0x00001D
databits = 8
scalingrpn = x,0.02,*

paramname = EngineLoad
paramid = 0x000007
databits = 8
scalingrpn = x,100,*,255,/

paramname = Manifold_Absolute_Pressure
paramid = 0xFF6394
isfloat = 1
scalingrpn = x,0.01933677,*


paramname = IPW ; injector #1 pulse width
paramid = 0x000011
scalingrpn = x,0.256,*


paramname = Knock_Sum*(count)
paramid = 0xFF7FEC
databits = 8
scalingrpn = x

conditionrpn = Coolant,76,>
action = start

conditionrpn = RPM,0,==
action = stop


Everything works except engine load, and CL/OL status. I am questioning MAFv but that may just be a resolution issue(numbers seem a little high for just cruising but the car is new to me so I have yet to really determine *normal numbers) . The issues with CL/OL status and engine load seem to either be incorrect scaling or incorrect paramid. Ive scoured the internet looking to correct these two params with limited success. I was able to fix many of the parameters I was targeting. (I am working on the GR stumble fix. I have a very slight stumble in the 28-3200 rpm range. Doesnt even happen very often. But I would like to smooth it out with the compensation tables for such issue.)

Any help would be appreciated. I tried pulling the data out of my logging xml file. But the values werent coming back scaled properly....
endrswrd
 
Posts: 1
Joined: Thu Oct 25, 2012 8:36 am

Re: Openport Stand-Alone Logging Beta

Postby rotorB » Sat Sep 21, 2013 7:10 am

Hi guys.

I want to log G-sensor of my Galant VR-4.
It works on EvoScan, but how can i add it to logcfg.txt, what value of 'type' parameter i should use?

Image
rotorB
 
Posts: 1
Joined: Sat Sep 21, 2013 6:56 am

Re: Openport Stand-Alone Logging Beta

Postby pete25r » Tue Nov 12, 2013 12:44 pm

I want to use RPm to trigger the logging to start

this was copied from another person I know but the it doesn't work

the logcfg.out file states theres something wrong with it

conditionrpn = RPM,0,>
action = start
;
conditionrpn = RPM,0,==
action = stop

also could you tell me what to set to start the logging at 2000rpm and finsih when it drops below 2000gwigga


change the "0"s

conditionrpn = RPM,2000,>
action = start
;
conditionrpn = RPM,1999,==
action = stop
pete25r
 
Posts: 4
Joined: Sun Sep 09, 2012 5:21 am

Re: Openport Stand-Alone Logging Beta

Postby kangsta » Thu Jan 28, 2016 6:46 pm

has there been any further development on this? Is there a central wiki or repository with documentation on the supported logging modes like more generic ISO 14230-4 KWP
kangsta
 
Posts: 1
Joined: Tue Aug 19, 2008 1:30 am

Previous

Return to Openport Stand-Alone Logging Beta

Who is online

Users browsing this forum: No registered users and 1 guest