ECUFLASH wont read ECU, now car wont start?

ECUFLASH wont read ECU, now car wont start?

Postby ccbremech » Wed Feb 06, 2013 11:14 pm

i have a 2004 USDM STI. I tried to read my ECU VIA ECUFLASH and it would not read it. Just kept saying "Interface closed." so then i tried to start the car and nothing. Electrical turns on and off and the car can be taken in and out of test mode when connecting the green test mode conectors, But the car will not turn over. Any ideas here? Any help would be greatly appreciated.

Side note: i was able to datalog VIA ROM Raider Before the read and it worked fine.
Posts: 1
Joined: Wed Feb 06, 2013 11:09 pm

Re: ECUFLASH wont read ECU, now car wont start?

Postby mporeda » Fri Mar 01, 2013 4:20 pm

I would have to see the whole log output but if there was an issue while reflashing and then you turned off the vehicle, you likely bricked your ECU. If you are ever interrupted while reflashing (USB cable comes unplugged, laptop loses power, etc.) you only need to fix the problem (ie plug in the cable, power the laptop) and restart EcuFlash. The program will pick up exactly where it left off because our kernel is handling the reflash. If, on the other hand, you turn the vehicle off, you lose the kernel, and you're left with whatever partial reflash you had when the issue was encountered, and a bricked ECU.
Posts: 38
Joined: Tue May 01, 2012 4:43 pm

Return to Subaru (all models)

Who is online

Users browsing this forum: No registered users and 4 guests