2008 EDM STI dont read map using Ecuflash

2008 EDM STI dont read map using Ecuflash

Postby subaru_sti_2008 » Fri Dec 07, 2012 11:43 am

Hi to everybody,

First of all excuse me if my english is not good, i am writing from Italy
Also excuse me if this is not the correct section

Just need an info on what is happening on my 2008 STI that i have bought second hand last week.

Well, i have upgraded in these years from a 2002 STI to a MY 2007 and now i bought a MY 2008 model (hatch) and always have flashed by myself my ecus without any problem.

Last night just connected the openport 2.0 to the car and i get this messages on the log:

[20:44:28.629] EcuFlash Version 1.42.2595
[20:44:28.629] OS Version Windows XP
[20:44:28.629] Qt Version 4.5.0
[20:44:28.649] 56 memory models read.
[20:44:28.649] scanning for metadata models in C:/Programmi/OpenECU/EcuFlash/rommetadata
[20:44:28.829] 343 ROM metadata models scanned.
[20:44:28.829] checksum module "subarudbw" loaded.
[20:44:28.829] checksum module "mitsucan" loaded.
[20:44:28.829] flashing tool "wrx02" loaded.
[20:44:28.829] flashing tool "wrx04" loaded.
[20:44:28.829] flashing tool "sti04" loaded.
[20:44:28.829] flashing tool "sti05" loaded.
[20:44:28.829] flashing tool "mitsukernel" loaded.
[20:44:28.829] flashing tool "mitsukernelocp" loaded.
[20:44:28.829] flashing tool "mitsubootloader" loaded.
[20:44:28.829] flashing tool "shbootmode" loaded.
[20:44:28.829] flashing tool "shaudmode" loaded.
[20:44:28.829] flashing tool "subarucan" loaded.
[20:44:28.829] flashing tool "mitsucan" loaded.
[20:44:34.557] J2534 API Version: 04.04
[20:44:34.557] J2534 DLL Version: 0.50.2598 Jun 26 2009 15:02:29
[20:44:34.557] Device Firmware Version: 1.10.2658
[20:44:36.140] kernel get version
[20:44:36.360] SSM2 init
[20:44:36.390] SSM2 ECU ID is 5A 42 78 42 07
[20:44:36.390] Requesting Seed...
[20:44:36.400] Sending Key...
[20:44:36.400] interface close
[20:44:36.420] interface close

Well, i dont know if car is still reflashed and the previous owner does not know because was the 3th° owner.
Car have some mods like upgraded water radiator, intercooler and oil cooler so i assume probably have been reflashed in the past but i have no acces to this information.

I removed the ecu from under the carpet on the passeger side to take a look and i found the two green test connectors near the ecu, tried to read with connector plugged togheter (like my old 2007 sti) but still same result.

Tried to read as 2005-2007 DBW STI or 2007+ DBW CAN STI but still same result

I was thinking that probalby was the openport 2.0 that was not running so i readed and modified the map from a 2008 Forester XT of a friend and everything goes fine.

Any idea?
I am seriously thinking that car had and Ecutek remap and now is locked.
In this case how i can discover this and unlock it ?

There are no Ecutek dealers in my area, the nearest one is 600km away!!!

Thank you in advance

Regards

Luigi
subaru_sti_2008
 
Posts: 2
Joined: Fri Dec 07, 2012 11:25 am

Re: 2008 EDM STI dont read map using Ecuflash

Postby subaru_sti_2008 » Sun Dec 09, 2012 3:34 am

Hi

Today i jest tried with new beta version of ecuflash but as you can see nothing changed, any suggestion?

Thanks

[12:31:10.809] EcuFlash Version 1.43.3150
[12:31:10.809] OS Version Windows XP
[12:31:10.809] Qt Version 4.6.2
[12:31:10.829] 62 memory models read.
[12:31:10.829] scanning for metadata models in C:/Programmi/OpenECU/EcuFlash/rommetadata
[12:31:11.029] 354 ROM metadata models scanned.
[12:31:11.029] checksum module "subarudbw" loaded.
[12:31:11.029] checksum module "mitsucan" loaded.
[12:31:11.029] checksum module "mitsuh8" loaded.
[12:31:11.029] patch module "Subaru CAN Enhanced RAM Parameter Logging" loaded.
[12:31:11.029] patch module "Mitsu CAN RAM Parameter Logging" loaded.
[12:31:11.029] flashing tool "wrx02" loaded.
[12:31:11.029] flashing tool "wrx04" loaded.
[12:31:11.029] flashing tool "sti04" loaded.
[12:31:11.029] flashing tool "sti05" loaded.
[12:31:11.029] flashing tool "mitsukernel" loaded.
[12:31:11.029] flashing tool "mitsukernelocp" loaded.
[12:31:11.029] flashing tool "mitsubootloader" loaded.
[12:31:11.029] flashing tool "shbootmode" loaded.
[12:31:11.039] flashing tool "shaudmode" loaded.
[12:31:11.039] flashing tool "subarucan" loaded.
[12:31:11.039] flashing tool "mitsucan" loaded.
[12:31:18.630] J2534 API Version: 04.04
[12:31:18.630] J2534 DLL Version: 1.00.3147 Sep 3 2010 00:11:07
[12:31:18.630] Device Firmware Version: 1.11.3137
[12:31:18.630] Device Serial Number: TAf$nuDv
[12:31:20.463] kernel get version
[12:31:20.683] VIN : JF1GRFLH38G021693
[12:31:20.683] CVN : FEF04D42
[12:31:20.693] SSM2 init
[12:31:20.723] SSM2 ECU ID is 5A42784207
[12:31:20.733] Requesting Seed...
[12:31:20.733] Sending Key...
[12:31:20.743] interface close
[12:31:20.753] interface close
subaru_sti_2008
 
Posts: 2
Joined: Fri Dec 07, 2012 11:25 am

Re: 2008 EDM STI dont read map using Ecuflash

Postby Jochen_145 » Sun Dec 09, 2012 10:26 am

Mhh... normaly this car should work

Maybe there is a ECUTek Tuning on.
You can try to read out the application set with ecuMem-Tool via SSM, if you got a simple KKL-Interface too.

So you can compare the readout with the stock dump and see, if the OBD is closed by ECUtek or simular

Jochen
Jochen_145
 
Posts: 70
Joined: Thu Nov 12, 2009 8:45 am

Re: 2008 EDM STI dont read map using Ecuflash

Postby tonyteam » Thu Aug 22, 2013 3:08 pm

luigi i'm italian ! have you resolved your problem?? if the car is previously tuned by ecutek is 100% protected in read ?
tonyteam
 
Posts: 1
Joined: Thu Aug 22, 2013 2:44 pm


Return to Subaru (all models)

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron