ECU Reading Frustrations

User topics relating to software that reflashes or modifes ECU code and data

Moderator: Freon

ECU Reading Frustrations

Postby warlock4u » Sat Sep 21, 2013 10:38 am

I should have named this thread "This ****ing software is driving me ****ing nuts".

I have a MY13 Forester that I am trying to read the ECU from. I am using the 2007+ CAN profile to read.

I have tried this on two machines.

Machine one: Win7/64 box.

Machine will not read _AT_ _ALL_. I can sometimes get to the "turn the car to the on position dummy" ok box, but most of the time, I just hit read, pick the 2007+ CAN, and it hangs, and drops me back to the software. When I CAN get to the Ok box, I get the following:
[18:35:15.475] kernel get version
[18:35:15.698] VIN : *******************
[18:35:15.704] CVN : ******
[18:35:15.704] SSM2 init
[18:35:15.740] SSM2 ECU ID is 8522346007
[18:35:15.744] Requesting Seed...
[18:35:15.752] Sending Key...
[18:35:16.685] kernel get version
[18:35:16.691] kernel version is : OpenECU Subaru SH7058 OCP CAN Kernel V1.06
[18:35:16.691] reading kernel comm buffer size
[18:35:16.696] comm buffer size set to 2048
[18:35:16.696] reading kernel flash buffer size
[18:35:16.701] flash buffer size set to 4096
[18:35:16.701] -- dumping ECU memory --
[18:35:16.709] kernel read area: addr: 00000000 len: 0800
[18:35:16.804] invalid / no kernel response to read
[18:35:16.804] kernel read area: addr: 00000000 len: 0800
[18:35:18.809] invalid / no kernel response to read
[18:35:18.809] kernel read area: addr: 00000000 len: 0800
[18:35:20.814] invalid / no kernel response to read
[18:35:20.814] ECU memory read failure.
[18:35:20.814] can't read image.
[18:35:20.817] interface close
[18:35:20.833] interface close

I have never gotten an image to read from this particular machine. Ever.

Machine 2: xp/32b.

Machine read the ECU ONE TIME. I got the box saying "Do you want to keep" and I was making a decision on what to do with that, and turned the car off. This crashed the software. Now, I get random CTD when I am using it. Sometimes I get as far as reading from the ECU, sometimes not. The CTD time seems random.

Here is what I have tried between the machines:

Uninstalling/reinstalling software.
Uninstalling/reinstalling software, and manually removing registry entries.
Moving the rommedata folder somewhere with out a space in the path.
Running the software as admin (on 7box)
Trying different cables, even going so far as to use a external HDD cable with two USB headers on it in the event the tactrix unit was not getting enough amperage to run.
re-downloading the software and scrubbing the old stuff off of each machine in the event that I got a bad download.

I am out of things to try here, I cannot possibly have this vehicle tuned with the software operating in this manner. I cant even get it to read more than one time, how can I possibly trust it to write.
Posts: 1
Joined: Sat Sep 21, 2013 10:28 am

Return to Reflashing Software

Who is online

Users browsing this forum: No registered users and 2 guests