Can't Read or flash my06 ADM Forrester 2.5i

User topics relating to software that reflashes or modifes ECU code and data

Moderator: Freon

Can't Read or flash my06 ADM Forrester 2.5i

Postby gillap » Mon May 18, 2009 11:03 pm

Hi,

I'm using version 1.41 with Tatrix 2.0 cable and have deleted and re loaded all drivers and ecu flash.

I have previously read and reflashed a number of these, I now have two ecu's that ECU flash won't read.

It identifies the ECU and then closes the interface.

no delay between ignition on and OK?

Any other suggestions please?

Cheers
gillap
 
Posts: 6
Joined: Sun May 27, 2007 2:03 am
Location: Sydney

Re: Can't Read or flash my06 ADM Forrester 2.5i

Postby radsdau » Tue May 19, 2009 3:49 pm

On those models, if you can read the ECU ID, then OpenPort2 should be configured correctly.
If it's not entering reflash mode, then either the Test Mode connector is not connected, or the ECU is locked (EcuTeK for instance).
I don't think there is as strict a requirement for delay between ignition on and entering reflash mode on these.
radsdau
radsdau
 
Posts: 674
Joined: Wed Feb 08, 2006 6:56 pm

Re: Can't Read or flash my06 ADM Forrester 2.5i

Postby gillap » Wed May 20, 2009 8:18 pm

The car is definitely entering test mode, ie test mode connectors collected and the fans cycle on and off when the ignition is on.

I can't imagine why the ECU would be locked by Ecutek or similar, as it is a naturally aspirated engine.

I have also tried moving the ecu, imobilser and key to another car and get the same result. Even though I can read and reflash that standard car's ecu.

I use these engines in a spyder 550 replica and only need to turn off a few DTC's because the is missing some bits . I've done four with no problems but now have two ecu's that ECU flash can't read.

Any help greatfully received! The owner wants his car!

Cheers
gillap
 
Posts: 6
Joined: Sun May 27, 2007 2:03 am
Location: Sydney

Re: Can't Read or flash my06 ADM Forrester 2.5i

Postby LOK11 » Thu May 21, 2009 12:41 am

Being NA, you might find it's a JECS ECU not a Denso ECU. Have you done the NA engines with this ECU before?

Regards
Lachlan Riddel
Technical Director
ChipTorque
http://www.chiptorque.com.au
User avatar
LOK11
 
Posts: 14
Joined: Mon Feb 06, 2006 12:27 am
Location: At Work (Too Often!!!) Australia

Re: Can't Read or flash my06 ADM Forrester 2.5i

Postby gillap » Thu May 21, 2009 3:31 pm

Yes I have reflashed these ECU's before.

It is a Denso ECU but maybe it is a MY07 not 06. I have however upgraded to the Tactrix 2.0 and downloaded the latest version of ECU flash. I also deleted all old versions and drivers.

Has anyone struck this before?

What is the solution please?

Cheers
gillap
 
Posts: 6
Joined: Sun May 27, 2007 2:03 am
Location: Sydney

Re: Can't Read or flash my06 ADM Forrester 2.5i

Postby gillap » Mon May 25, 2009 5:28 am

A bit more information

My generic scan tool won't connect to these ECu's either but has happilly done so with others.

I can log using Romraider.

I think I might have an 08 ECU here has anyone been able to read one of these yet?

Cheers
gillap
 
Posts: 6
Joined: Sun May 27, 2007 2:03 am
Location: Sydney


Return to Reflashing Software

Who is online

Users browsing this forum: No registered users and 4 guests