ECUFlash 1.3 Unable to read MY04 JDM Legacy GT Spec B

User topics relating to software that reflashes or modifes ECU code and data

Moderator: Freon

Postby cboles » Wed Apr 04, 2007 3:51 pm

I'm not sure what processor the 04 JDM LGT has. You communications look good up until the point of failure. Have you tried selecting the 2005+ model drive by wire vehicles instead when you try to read?

Colby
cboles
Site Admin
 
Posts: 1233
Joined: Wed Dec 29, 2004 5:45 pm
Location: Seattle, WA

Postby chipman » Thu Apr 05, 2007 5:50 am

In last two days I have tried 2 different cars (2003 WRX EUR and EVO8 EUR) to read with v. 1.30 and no success at all. I was able to read (and still am) with 1.29a.
Also colleague from Ukraine had the same problem with Subaru and Evo8.
So it seems that problem is in new version. Reading procedure remains the same.
chipman
 
Posts: 8
Joined: Tue Nov 07, 2006 6:59 am

Postby crash » Tue Apr 17, 2007 10:24 am

I"m getting the same error on my 05 USDM LGT 5MT.

ERR hC on the dash, ECUFlash reports an error as well

I've tried 1.29a and 1.30.

1.28 won't even run on my XP laptop.
crash
 
Posts: 6
Joined: Tue Jun 14, 2005 12:13 pm

Postby crash » Thu Apr 19, 2007 1:47 pm

Ok, I finally got 1.28 to work on the lappy, and still no go...

Here's the log from the last time I had 1.29a installed:

[00:13:19.156] Version 1.29.906
[00:13:19.171] 8 memory models read.
[00:13:20.906] 140 ROM metadata models read.
[00:13:20.906] checksum module "subarudbw" loaded.
[00:13:20.906] flashing tool "wrx02" loaded.
[00:13:20.906] flashing tool "wrx04" loaded.
[00:13:20.906] flashing tool "sti04" loaded.
[00:13:20.906] flashing tool "sti05" loaded.
[00:13:20.906] flashing tool "mitsukernel" loaded.
[00:13:20.906] flashing tool "mitsukernelocp" loaded.
[00:13:20.906] flashing tool "mitsubootloader" loaded.
[00:13:36.953] ssm2_init
[00:13:37.093] ECU ID is 2F 12 78 55 06
[00:13:37.109] ssm2_cmd_0x81
[00:13:37.140] ssm2_cmd_0x83
[00:13:37.203] denso challenge-response
[00:13:37.250] challenge is AD BA 21 2F
[00:13:37.250] response is 00 A6 16 1C
[00:13:37.296] ssm2_cmd_0x10
[00:13:37.656] validating denso kernel ram area addr: FFFF3000 len: 0C28
crash
 
Posts: 6
Joined: Tue Jun 14, 2005 12:13 pm

Postby blue.taxi » Fri Apr 20, 2007 12:46 am

it seem like the ecuflash cannot support the non-USDM WRX from MY03-, I hv try may time & way to read the rom. Until now still no go for me.
blue.taxi
 
Posts: 61
Joined: Sun Jul 23, 2006 8:38 am

Postby crash » Tue May 08, 2007 7:20 am

Ok, I'm a moron...

I was connecting the green connectors by the fuse box (driver's side USDM) and I needed to connect the green connectors over by the ECU (passenger side USDM)

I was able to pull my stock ROM down last night with no problem.
crash
 
Posts: 6
Joined: Tue Jun 14, 2005 12:13 pm

Postby in1t » Mon Jul 28, 2008 2:47 pm

in1t
 
Posts: 18
Joined: Fri Jul 18, 2008 11:36 pm

Re:

Postby aijet » Sun Aug 19, 2012 11:41 pm

crash wrote:Ok, I'm a moron...

I was connecting the green connectors by the fuse box (driver's side USDM) and I needed to connect the green connectors over by the ECU (passenger side USDM)

I was able to pull my stock ROM down last night with no problem.


Does anyone know where to connect Green connectors?

It cannot read my LGT 05, but I can read LGT 07 ( friend's car)
aijet
 
Posts: 1
Joined: Sun Aug 19, 2012 11:30 pm

Previous

Return to Reflashing Software

Who is online

Users browsing this forum: Bing [Bot] and 3 guests

cron