Get newest versions of EcuFlash from the website

OpenECU software executables and source code

Moderator: Freon

Postby MRF582 » Sun Oct 15, 2006 7:25 pm

Colby - I have reason to believe that 1.29a doesn't support OpenPort 1.1.

On a virgin laptop that has never had any OpenECU software...

Installed ECUflash129a.exe (updated/fixed the driver install bug)
ECUflash doesn't respond. "No Vehicle Interface" detected. The program intsalled fine and it even ran the openport driver setup. ECUexplorer is able to log data at this point.

Uninstalled 1.29a and installed ECUflash 1.27. This time I noticed the driver installation is different. It looks like it installs a different set of drivers as compared to 1.29a. So now my OpenPort 1.1 cable works fine with 1.27

Any thoughts?
Posts: 34
Joined: Thu May 19, 2005 11:25 am

Postby Hobbes » Mon Oct 16, 2006 7:01 am

I had the same problem (no interface). I fell back to 1.28 and also noticed that 3 drivers were loading in 1.28. verses 2 in 1.29a.


Tactrix CDM Driver Package
Tactrix CDM Driver Serial Port Package


FTDI FTDI VCP Driver Package
FTDI FTDI VCP Driver Package
Tactrix Open Port Vehicle Interface Drivers

Posts: 27
Joined: Sat Jul 16, 2005 6:41 pm

Postby qoncept » Wed Oct 18, 2006 9:42 am

Any news on the source?
Posts: 249
Joined: Tue Oct 04, 2005 6:43 pm
Location: Montgomery, AL

Postby ride5000 » Wed Oct 18, 2006 12:02 pm

i also had to revert back to 128, for the same reason.

Posts: 44
Joined: Tue Feb 01, 2005 12:18 pm
Location: lincoln, ri

Postby Freon » Wed Oct 18, 2006 12:19 pm

Trying removing both Ecuflash AND the FTDI drivers via Add/Remove programs in Control Panel. Then reinstall Ecuflash 1.29a.
Posts: 700
Joined: Thu Nov 17, 2005 5:50 pm
Location: Indianapolis, IN

Postby twg » Wed Oct 18, 2006 8:12 pm

Yes, I had the same problem..

until I uninstalled ECUFlash AND the older FTDI drivers... then EcuFlash v1.29a worked for me...
Posts: 46
Joined: Fri May 27, 2005 9:03 pm

Postby chrisw » Mon Oct 23, 2006 8:21 pm

Freon wrote:Trying removing both Ecuflash AND the FTDI drivers via Add/Remove programs in Control Panel. Then reinstall Ecuflash 1.29a.

I tried this with no success. It looks like I have to revert to 1.28 as well.

Using mitsulogger, I was able to connect briefly, but in the end the connection would always be lost.

I was able to get to the vehicle interface, but every time I attempted to connect, the connection would fail at random points. Either I would succeed through the init sequence and fail on the ROM download, or I would fail in the init sequence.

This is on an '03 EVO8
Posts: 30
Joined: Tue Apr 25, 2006 7:09 pm

Postby MalibuJack » Mon Oct 23, 2006 8:49 pm

Also, you might want to verify its not the cable or the car.. Try reading the ECU on a different Evo, also try the cable on another computer.. If it works then you can narrow down the problem a little.

The drivers, both the old and new versions, leave a bunch of crap behind even when you uninstall it, and you may have to go through and manually delete all the driver files left behind in windows\system32 and windows\drivers directories, additionally you may have to go through the registry and remove those entries for the FTDI device, HKEY_LOCAL_MACHINE\CURRENT\SERVICES\FTDI or something to that effect..

Then you can reboot the machine, and reinstall the 1.29a driver package in c:\program files\openecu\ecuflash\drivers I think is where its located using the installer executable (dpinst.exe)

Then plug the cable in

when it asks to check the internet for updated drivers, select "not this time" then next install from a specific directory, then browse to the same directory where the driver is located.

This should give you a clean install.

Forgive me if there are typos or slight errata, I am doing this from memory.
Posts: 128
Joined: Tue Apr 25, 2006 12:10 pm
Location: Royse City, TX

Postby chrisw » Mon Oct 23, 2006 9:17 pm

yeah, after I did a manual removing of the older (and several different versions of) the FDTI drivers, I was able to get 1.28 to work.

But it only worked after unplugging my ECU+ from the EVO.

the logging tools are still having issues, but I suspect that I didn't clean out all the old drivers properly.
Posts: 30
Joined: Tue Apr 25, 2006 7:09 pm

Postby merchgod » Thu Oct 26, 2006 9:12 pm

edit: updated in another post
Last edited by merchgod on Sat Jan 26, 2008 6:52 am, edited 1 time in total.
Posts: 243
Joined: Fri Sep 29, 2006 10:17 am

Re: flashing tool "evo" loaded ?

Postby Kuksauto » Sun Feb 18, 2007 6:03 pm

cboles wrote:
YP wrote:[04:56:10.452] flashing tool "evo" loaded.

Sorry, I don't understand - does it work on Mitsubishi's ?
with 16V on PROG ECU pin of course.

That code is already done, but you need hardware which supports an electronically controlled PROG ECU pin. I will release another version in a couple of weeks when the hardware is available.




How about manual control of 16 V program pin?
Before start, make push button for start program?
Is it easy way ?


Kuk Won Ko
Posts: 2
Joined: Sat Feb 17, 2007 12:25 am
Location: South Korea


Postby Denis 1982 » Sat Jul 28, 2007 11:50 am

Greetings, guys! You disturb from Russia, we have a problem - cannot consider an insertion with WRX STI 2.5 06 of release, managements of the block of the engine: 22611AL340.
We use program EcuFlash of version 1.30.1095. All green sockets are closed, but the program writes: unable to connect to vehicle interface. Prompt what to make, that the program would earn... :oops:
Denis 1982
Posts: 4
Joined: Wed Dec 20, 2006 2:39 am

Postby Slowsoul » Sun Jan 20, 2008 1:59 pm

I downloaded the OSX version of EcuFlash but when I attempt to open the .dmg file it tells me that "it is not supported by this archetechture"

I am running OSX v 10.5.1 (leopard) on my Powerbook G4.

Posts: 3
Joined: Sat Jan 19, 2008 3:17 pm
Location: Atlanta

Postby cboles » Sat Jan 26, 2008 1:40 am

slowsoul: Unfortunately the OS X release is for x86 only.

denis: Can you send me a log to so I can see what is going wrong?
Site Admin
Posts: 1233
Joined: Wed Dec 29, 2004 5:45 pm
Location: Seattle, WA

Postby Slowsoul » Wed Feb 06, 2008 4:39 pm

cboles wrote:slowsoul: Unfortunately the OS X release is for x86 only.

Pardon my unfamiliarity, but what is x86?
Posts: 3
Joined: Sat Jan 19, 2008 3:17 pm
Location: Atlanta


Return to OpenECU Software

Who is online

Users browsing this forum: Google [Bot] and 1 guest