can not load 1.3u drivers.

User topics relating to hardware that interfaces PCs to ECUs

Moderator: Freon

can not load 1.3u drivers.

Postby coldturbo » Thu Apr 09, 2015 6:10 am

I have tried 4 PC, each gets the exact same error. Don't matter was version of ECUFlash I try with I can not load up the Com ports for my 1.3u cable.

Each time the following error message displays:
An error occurred during the installation of the device: The driver installation file for this device is missing a necessary entry. This may be because the INF was written for Windows 95 or later. Contact your hardware vendor.

I tried all my known methods of getting the windows 8.1 device manager to load up the correct drivers by manual install but all fail with error 28 or error 1. I tired the drivers in the ecuflash folder as well as the raw ‎Virtual COM Port Drivers of the ftdichip.
Please let me know if you need any more information.

Thanks for the help.
coldturbo
 
Posts: 3
Joined: Sat May 03, 2008 8:45 pm

Re: can not load 1.3u drivers.

Postby InjectedSTi » Sun Apr 12, 2015 9:15 pm

Came in here looking to make a post of my own and stumbled across yours instead. I'm having the exact same issue you're having except I'm on a Windows 7 x64 machine. I see you've gotten no kinda help up in here so I'm gonna email Cobly about this and see if he has any advice for resolving this issue. It's got to be something related to newer FTDI drivers because I've never had an issue with my 1.3 cable in the past. I've tested this on two different machines but keep getting the same error on both.

Here are some screenshots I took of the error when trying to use the drivers from EcuFlash v1.44.4361 that hopefully might be of help.

http://i.imgur.com/XmK39wh.png
http://i.imgur.com/LGovqX9.png
http://i.imgur.com/mQjZbVE.png
http://i.imgur.com/Q2HYajg.png



FYI, I was able to get my 1.3 cable up and running using the drivers from EcuFlash v1.44.3721 and as a matter of fact, I was able to UPDATE to the drivers from v1.44.4361 AFTER I installed the drivers from v1.44.3721.

So basically...
- I uninstalled all the current drivers from the system.
- Go into Control Panel > Programs and Features and make sure to uninstall BOTH Tractrix Drivers towards the bottom of the list.
- Also with your cable plugged in, go into "Device Manager > Ports" and right-click on anything in there that says "OpenPort" or "USB Serial Port" etc. Then select "Uninstall" and make sure you check the box that says "Delete the driver software for this device".
- Then under "Universal Serial Bus controllers" look for "OpenPort 1.3 Subaru" and right-click and Uninstall that as well making sure to check the box that says "Delete the driver software for this device".
- Then I ran "DPInst.exe" from the "drivers\openport 1.3\" folder. EcuFlash v1.44.3721
- Then after everything installed without any errors I ran "DPInst.exe" from the "drivers\openport 1.3\" folder. EcuFlash v1.44.4361

I noticed that it might be best leave the Tactrix cable plugged in while doing all this. There were a few times during testing that I didn't have the cable plugged in before I ran DPInst.exe and then I plugged it in afterwards and I still got the error message, even with the drivers from v1.44.3721. So make sure that you try it with the cable plugged in if you're still having issues.
InjectedSTi
 
Posts: 1
Joined: Sun Oct 03, 2010 1:14 am

Re: can not load 1.3u drivers.

Postby coldturbo » Fri May 22, 2015 2:30 pm

I tried your methods but still got nothing. I now bought a 2.0 cable and still nothing which makes no sense at all. No com ports, nothing. I'd love help from someone, anyone.
coldturbo
 
Posts: 3
Joined: Sat May 03, 2008 8:45 pm


Return to Interface Hardware

Who is online

Users browsing this forum: Google [Bot] and 2 guests