02 WRX timeout on read for ECU Type

User topics relating to hardware that interfaces PCs to ECUs

Moderator: Freon

02 WRX timeout on read for ECU Type

Postby gbergstedt » Tue Sep 04, 2012 7:42 am

Hi All,

I did the following:
1) Key off
2) connect jumper
3) Don't connect green connectors (test mode)
4) Run Ecu Explorer (Debug console on)
5) Adjust comm port setting as suggested in Manual (also tried with standard settings)
5) Connect Openport 2.0 plug
6) Turn key to ON

I get a continuous stream of:

08:32:31.609 - to ECU : QueryECUType
08:32:32.859 - Response Timeout - QueryECUType
08:32:32.859 - QueryECUType failed with 4103 [0x1007]

When I run RomRaider Logger, I get a good connection to the ECO and can log values.

Any ideas?
Posts: 1
Joined: Tue Sep 04, 2012 7:26 am

Re: 02 WRX timeout on read for ECU Type

Postby pete25r » Sun Sep 09, 2012 7:06 pm

3) Don't connect green connectors (test mode)

...that's what's holding you back. both test connectors and jumper have to be connected.

I made a switch out of an old PC voltage selector switch (120/220v), a couple of male and female spade connectors.
So normal driving mode I have the switch in the off position and the wires are not connecting the green test con. or the jumper. Slide the switch which connects the test and jumper, read and flash all day/night long.
Posts: 4
Joined: Sun Sep 09, 2012 5:21 am

Return to Interface Hardware

Who is online

Users browsing this forum: No registered users and 2 guests