08 WRX USDM EcuFlash HELP!!

User topics relating to hardware that interfaces PCs to ECUs

Moderator: Freon

08 WRX USDM EcuFlash HELP!!

Postby colby1321 » Thu Jul 07, 2011 7:31 am

I have the openport 2.0 for my 08 wrx. Installed romraider and ecuflash and all the recent definitions and everything.

I plug the op 2.0 into the car while its off and into the computer, then click read from ecu and the list to select my car from comes up blank. Ive also tried to hook it up with the car in the on position and still get the same problem. Hook the op in when cars off, turn the key to on and cliuck read from ecu, and still the list comes up blank.

No matter what I try, it comes up blank. Ecuflash says Openport 2.0 on COM 4 in the lower right corner but it like doesnt recognize my car. Someone please help me! Ive tried unistalling ecuflash and the drivers for the OP and reinstalling and still no fix.

This is the log from when i try to read ecu and i attached a screenshot of when i try to read ecu too.

[18:56:25.317] EcuFlash Version 1.42.2595
[18:56:25.317] OS Version Windows Vista
[18:56:25.317] Qt Version 4.5.0
[18:56:25.328] 56 memory models read.
[18:56:25.329] scanning for metadata models in C:/Users/Colby/Downloads/ECUFLASH STANDARD units SUBARU ECU definitions 0.8.3.1b 10-07-09 (1)/subaru
[18:56:36.761] 333 ROM metadata models scanned.
[18:56:36.761] checksum module "subarudbw" loaded.
[18:56:36.761] checksum module "mitsucan" loaded.
[18:56:36.762] flashing tool "wrx02" loaded.
[18:56:36.762] flashing tool "wrx04" loaded.
[18:56:36.762] flashing tool "sti04" loaded.
[18:56:36.763] flashing tool "sti05" loaded.
[18:56:36.763] flashing tool "mitsukernel" loaded.
[18:56:36.763] flashing tool "mitsukernelocp" loaded.
[18:56:36.763] flashing tool "mitsubootloader" loaded.
[18:56:36.763] flashing tool "shbootmode" loaded.
[18:56:36.766] flashing tool "shaudmode" loaded.
[18:56:36.766] flashing tool "subarucan" loaded.
[18:56:36.767] flashing tool "mitsucan" loaded.
Attachments
Capture 1.JPG
Capture 1.JPG (88.15 KiB) Viewed 5790 times
colby1321
 
Posts: 7
Joined: Thu Jul 07, 2011 7:19 am

Re: 08 WRX USDM EcuFlash HELP!!

Postby colby1321 » Thu Jul 07, 2011 12:25 pm

do i need internet connection when i try to read the ecu? When i try to read the ecu and such i dont have any internet connection, would that cause my problem?
colby1321
 
Posts: 7
Joined: Thu Jul 07, 2011 7:19 am

Re: 08 WRX USDM EcuFlash HELP!!

Postby radsdau » Thu Jul 07, 2011 4:25 pm

I don't *think* you need an internet connection for that to work, but everything else looks ok to me. It finds the defs etc which is what normally would mess things up.
The only thing that is different to mine is the OP2 isn't on a com port; mine just says "(USB)", but it is a later version. Try downloading one of the 1.43 Betas; there's a link on the EVOScan website.
radsdau
 
Posts: 674
Joined: Wed Feb 08, 2006 6:56 pm

Re: 08 WRX USDM EcuFlash HELP!!

Postby colby1321 » Thu Jul 07, 2011 9:18 pm

Does it look good still? Thats the beta after being downloaded. not hooked up to car
Attachments
Capture2.JPG
Capture2.JPG (79.47 KiB) Viewed 5772 times
colby1321
 
Posts: 7
Joined: Thu Jul 07, 2011 7:19 am

Re: 08 WRX USDM EcuFlash HELP!!

Postby colby1321 » Sat Jul 09, 2011 8:23 am

downloaded the beta verison and now it doesnt recognize the openport 2.0 and saysit needs to download a driver or something even thought the installation for the beta installed an op 2.0 driver
colby1321
 
Posts: 7
Joined: Thu Jul 07, 2011 7:19 am

Re: 08 WRX USDM EcuFlash HELP!!

Postby radsdau » Sun Jul 10, 2011 3:42 pm

Yes, upgrade the OP2 firmware and drivers.
radsdau
 
Posts: 674
Joined: Wed Feb 08, 2006 6:56 pm

Re: 08 WRX USDM EcuFlash HELP!!

Postby colby1321 » Mon Jul 11, 2011 8:09 am

radsdau wrote:Yes, upgrade the OP2 firmware and drivers.



and how would i do that?
colby1321
 
Posts: 7
Joined: Thu Jul 07, 2011 7:19 am

Re: 08 WRX USDM EcuFlash HELP!!

Postby radsdau » Mon Jul 11, 2011 7:05 pm

For me it happened automatically after I installed the new software and connected the cable. Other than that, I don't know.
radsdau
 
Posts: 674
Joined: Wed Feb 08, 2006 6:56 pm


Return to Interface Hardware

Who is online

Users browsing this forum: No registered users and 2 guests