Ecuflash and Tactrix cables killed Lancer X 1.5 ECU

Announcements, dicussion about any topic that would have broad interest to the forum members

Moderator: Freon

Ecuflash and Tactrix cables killed Lancer X 1.5 ECU

Postby completechip » Wed Apr 30, 2014 12:29 am


My name is Stacescu Dragos, I own a little tuning company in Romania ( , specialised in both diesel and petrol european engines.

Recently I wanted to extend the car model area to japanese models, I have bought for personal study and use a 2002 Subaru WRX and I chose Tactrix cable to be the first interface to be used in the process of tuning the car.

So I purchased Tactrix cable on 08dec 2013,

Item Title:
Order Number: 14293
Invoice ID:

I received the cable 2-3 weeks after payment done via Paypal, having ZERO documentation ( no user manual ). The cable was initially achieved for my personal Subaru, as I said, so once I've got the cable having no documentation I tried to read/write the ecu to see how the interface works.

It took me half a day to realise that beside the test mode connector that must be bridged, there is another reflash connector that must be plugged, this being a conclusion after 3-4 hours of searching on the forum to find same issues as I had. Anyway, this is just a simple story, maybe my level of knowledge is zero and I am too "stupid" to own this cable. In the end I managed to read the ecu, modified it, reflashed it, car works like a charm.

Now let's get to the point of our topic:

This Monday we had a customer entering our workshop, owner of a Lancer X 1.5 N/A, 2008 my, who wanted just a simple raise of RPM CUT point.

I plugged the Tactrix cable, selected "mitsucan" protocol ( 2006+ CAN based mitsubishi ), and tried to read the ecu. I got an error while trying to read the ecu ( I repeat, I just pressed the "read" button ) and from this moment on there was no communication with the engine ecu on CAN network.

I diagnosed the ETACS unit and immo unit, both had PCM timeout CAN communication errors. Diagnosis of engine ecu was possible, but only on K-line, on CAN - ecu acted like it was dead.

What followed after this failure was a painful and awful series of attempts to bring ecu back to life. After starting to search the web for same issues, I got here:

and here: ... sh-377008/

, where it seems some other users of same Ecuflash+Tactrix cable had same issue and resulted in dead engine units.

Conclusion was that 93s66 eeprom content was corrupt, inhibiting CAN communication with the ecu, ecu acting like being stuck in bootmode.

I will not share the repair method, I will just tell you that I had to reach for the eeprom, which is installed on back of PCB, so ecu plastic case had to be cut, I think I desoldered/read/write/soldered back the 93S66 eeprom more than 50 times to make tests, in the end the car was restored with a certain content written by me inside the eeprom ( not the original content, obvious, which was corrupt ) and with the help of MUT3 tester from the local Mitsu dealership.

The guys from ( user name Bruce Willis, also on this forum ) know this issue and have solution for it, the MMCFLASH software has unlock button to bring ecu back to life.

Considering I was not warned in any way about this possible failure, considering here < ... &Itemid=41 > it is clearly stated that the cable works on " basically any Mitsubishi ECU based on a H8, SH-2, or M32r processor", I would like to ask the owner of this forum and the Tactrix cable supplier who is going to pay for the costs of labour for bringing ecu back to life, for the costs of entering the dealership , for the costs of renting a car for the customer as his car was immobilised all this time.

I will contact the Tactrix supplier and bring this to his knowledge, I have invoices for all services that had to be made to get the car back to life. If I will not get my money back, I will press charges against the supplier.

This topic is intended for all of you to know that ECUFLASH + TACTRIX will kill the Lancer 1.5 N/A 2008 ecu by simply pressing READ button.
Posts: 4
Joined: Mon Jan 13, 2014 12:03 am

Re: Ecuflash and Tactrix cables killed Lancer X 1.5 ECU

Postby cboles » Wed Apr 30, 2014 10:16 am

If you have an error during a read, you can just select "Exit programming mode" from the menu and the ECU will return to the normal state (which does set the flags in the SEEPROM correctly). There is no reason you would ever have to take this ECU apart, even if it was completely bricked from programming bad code into it. Please contact next time you have a problem.
Site Admin
Posts: 1233
Joined: Wed Dec 29, 2004 5:45 pm
Location: Seattle, WA

Re: Ecuflash and Tactrix cables killed Lancer X 1.5 ECU

Postby completechip » Wed Apr 30, 2014 11:39 am

I think you are missing the point here.

After pressing the magic "read" button, there was nothing more to be done - ecu died - I made 10-15 attempts to connect again to it - nothing. There was no "exit programming state" feature selectable anywhere.

And please take this discussion to the proper level, I am not a parking lot amateur tuner, I have enough knowledge in this ecu stuff as I am one of the few able to repair broken OBD flashed TPROT EDC17's Bosch ecu's in Romania, so I am not kidding with the things mentioned. It would have been ridiculous for me to make all the efforts I made to bring the car back to life if I had a "magic" button called "exit programming state". Don't you understand that Ecuflash wasn't able to communicate at all with the computer??? After first attempt error, reffering to "seed key init error", there was no chance to reach ecu on CAN. There was no connection to the ecu, nothing. I could read the ecu on the bench via K-line with different tool, read/write ok via K-line, I repeat, but on CAN it failed to communicate.

There is a BUG in your protocol and people from MMCFLASH.Ru know about it: their software has the "unlock" feature enabled to repair the broken ecu's from Lancer 1.5 - they even have a special module for it: ... t&Itemid=6

I really find it hard to believe they developed special module for this 1.5 N/A Lancer unless your software kills these ecu's.

Still waiting for your official answer, a serious one this time.

Please put this link into google translate, from russian to english :

This way you will realise I am not the only one having this problem.
Posts: 4
Joined: Mon Jan 13, 2014 12:03 am

Re: Ecuflash and Tactrix cables killed Lancer X 1.5 ECU

Postby completechip » Wed Apr 30, 2014 2:22 pm

Tactrix support just stated that under ECU menu this "exit programming state" feature is enabled. Maybe, only if you manage to connect to ECU! The TOOL NEVER MANAGED TO CONNECT THE ECU, IT JUST BRICKED IT WHEN LAUNCHING READING SEQUENCE ( seed key init error ).

Check the picture, no other option than "read ecu", which was impossible.

Here is link to printscreen from Ecuflash:
Posts: 4
Joined: Mon Jan 13, 2014 12:03 am

Re: Ecuflash and Tactrix cables killed Lancer X 1.5 ECU

Postby completechip » Wed Apr 30, 2014 2:31 pm

More than this, the Ecuflash software did not recognize the 512kb ROM content read via K-line from this ECU with different tool, I mean it is sending me to wizard to create new definition file. I specify this because tactrix support stated this:

" In order to use the "Exit Programming State" feature (see attached image), EcuFlash needs to know what ECU type your are working with. On older versions of EcuFlash, you need to have a mitsucan ROM loaded to see these menu options. In newer EcuFlash versions, you can select a vehicle type without actually having a ROM loaded, then take the same action. The ECU enters the programming state (which is stored persistently in the SEEPROM) whenever you are doing a read or write and exits it when the process completes, so if something fails in the process, you will need to exit the state before ECU will work normally again. "

I have newest Ecuflash version and I cannot select anything you stated above. Maybe this works once you connect the ECU, which failed to happen in my case.
Posts: 4
Joined: Mon Jan 13, 2014 12:03 am

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests