Kawasaki Z750 ECU Protocol??

Announcements, dicussion about any topic that would have broad interest to the forum members

Moderator: Freon

Kawasaki Z750 ECU Protocol??

Postby Neil » Tue Aug 07, 2007 2:43 am

Kawasaki Z750 ECU Protocol??

I am trying to connect a Scantool to my 2004 Kawasaki Z750 but it doesnt appear to talk. I am using the ELM327 interpreter Chip with software from scantool.net

If I talk to it with a Terminal program and set the protocol to ISO9141 I see "INIT ... ERROR"

The Kawasaki has a Denso ECU with a 4 pin diagnostic connetor under the seat. The diagnostic connector pins are as follows: (As described in the Mantainance Handbook)
1/ +12volts
2/ Gnd
3/ Self-diagnosis Terminal. If this pin is grounded the ECU will give Blink Codes.
4/ External Diagnosis System Signal. This is connected to terminal 46 on the ECU, and when measured with a multimeter shows approx 7.5 volts at rest.

I am assuming the ECU is talking ISO9141 as it only has a "single wire" for diagnositics and is sitting at 7.5 volts at rest. (Maybe not the correct assumption). I did try VPM which is also single wire interface but had NO success.

The ELM327 has a number of programmable options for ISO/KWP. I have tried all combinations including:
- ISO,KWP slow,KWP slow
- setting ISO interface baud rate to 9600 (Default is 10400)
- Changing the int. address from 33 to 30,03 (just guessing here really)
- Disabling Keyword checking
- Bypassing Init

I have done a buffer dump of the ELM327 and it confirms that I have not received anything back from the ECU.

I know the ELM327 is working OK as I have connected it to 2 cars. a Holden Astra (CAN) and Nissan X-Trial running ISO and can get Sensor/DTC info from them.

Is the Kawasaki really ISO9141? or it running a different Baud rate?

Any Ideas.

regards Neil..
Neil
 
Posts: 1
Joined: Sun Jul 22, 2007 11:31 pm
Location: Melbourne

Postby mickeyd2005 » Fri Aug 17, 2007 10:54 pm

mickeyd2005
 
Posts: 26
Joined: Thu Sep 28, 2006 10:26 pm

Re: Kawasaki Z750 ECU Protocol??

Postby tomari » Fri May 27, 2011 6:48 am

hello my friends, sorry for topic digging but there is no info about this anywhere!
can u help?

about this 4 pin connectr could it be a TTL or something? or maybe oneway RS232?
i dont think its an obd protocol in anywhay.

anyone can help abou this?
tomari
 
Posts: 1
Joined: Fri May 27, 2011 6:35 am

Re: Kawasaki Z750 ECU Protocol??

Postby Bruce Willis » Sat Aug 27, 2011 5:50 am

MMCflash can read this ecu
Bruce Willis
 
Posts: 58
Joined: Sat Jan 24, 2009 7:41 am
Location: Russia


Return to General Discussion

Who is online

Users browsing this forum: Bing [Bot] and 1 guest